Úvodní informace o programu DreamCom

Kubik SMS DreamCom

Tento program je určen na rozesílání SMS zpráv zejména po ČR, ale také do celého světa.

Kdo nemá chuť na dlouhé čtení, tady je jakýsi nejstručnější návod:

Instalace

Spusťte instalační soubor a vyberte adresář, do kterého chcete program nainstalovat. Hned po spuštění programu můžete začít posílat zprávy.

Psaní zpráv

Napíšete číslo adresáta dáte Enter, napíšete zprávu, dáte Ctrl+Enter a zpráva je odeslána.

Tento program je shareware, registrační poplatek je 300 Kč. V neregistrované verzi se zobrazuje okno s reklamním pruhem, na které musíte po určitém čase kliknout. Informace o registraci a omezních neregistrované verze najdete zde.

Aktuální možnosti a ceny odesílání SMS zpráv najtede na našich stánkách.

Nahoru


Hlavní okno

V hlavním okně se soustřeďují nejdůležitější funkce programu: Editor zpráv, Fronta, Historie, Přijaté zprávy a Adresář. Kliknutím na trojůhelík vedle tlačítka Nová zpráva zvolíte typ zprávy: SMS zpráva, Obrázková zpráva, Melodie či Email.

(Ctrl+G) Otevře okno pro nastavení skriptu pro jedno odeslání (více viz Skripty).

(Alt+O) Otevře databázové okno Odkazy. Kliknutím na trojúhelník vedle ikonky se otevře nabídka odkazů. Kliknutím na vybraný odkaz se tento otevře v prohlížeči.

(Alt+T) Otevře databázové okno Šablony zpráv. Kliknutím na trojúhelník vedle ikonky se otevře nabídka šablon.

display1.bmp (1418 bytes) (Alt+D) Zapne funkci Flash SMS. Odesílanou zprávu pošle přímo na displej mobilního telefonu.

dorucenka.bmp (1334 bytes) (Alt+P) Zapne funkci Potvrzení o doručení. SMS centrum pošle potvrzení o přijetí zprávy.

identifikace.bmp (774 bytes) (Alt+I) Zapne funkci Identifikace. K odesílané zprávě jsou připojeny informace o odesílateli (jaké záleží na SMS bráně operátora).

Pokud je některé z tří výše uvedených tlačítek zakázáno, SMS brána vybraného operátora tuto funkci nepodporuje.

Adresář

Zajišťuje rychlý přístup k osobám v seznamu. Před odesláním zprávy je nutno nejprve vybrat alespoň jednu osobu z adresáře (nebo zadat nové číslo). Stisknutím pravého tlačítka myši v okně adresáře vyvoláte kontextovou nabídku, z které máte možnost smazat osobu ze skupiny (ve skupině Všichni z adresáře) nebo vyvolat editační okno adresáře.

Vyhledávat jména nebo čísla je možné přímo v adresáři (nemusíte se přesouvat do vyhledávací řádky). Stisknutím klávesy Enter se přesunete přímo do editoru textu. Kontakt se vybírá buď kliknutím myši na ikonku operátora nalevo od jména, stisknutím mezerníku nebo poklepáním myší.

Fronta

Ve frontě jsou seřazeny zprávy, které čekají na odeslání. Položka ve frontě je označena jménem adresáta a barevnou ikonkou. Zelená ikonka znamená, že zpráva se právě odesílá. Oranžová ikonka znamená, že je zpráva připravena k odeslání (např. čeká na časový limit SMS brány). Červená ikonka znamená, že zpráva bude odeslána později. Stisknutím pravého tlačítka myši v okně adresáře vyvoláte kontextovou nabídku

Vyhledávací řádka

Je určena k rychlému vyhledávání osob v adresáři. Napište část jména nebo čísla, které chcete vyhledat, a pokud bude odpovídající jméno (číslo) nalezeno, vybere se v adresáři.

Pro usnadnění práce slouží ve vyhledávací řádce několik klávesových zkratek:

  • Enter - Kurzor se přesune z vyhledávací řádky do editoru.
  • Ins - Zaškrtne (zruší zaškrtnutí) modře vysvícené jméno v adresáři. Zadáte-li číslo, které není v seznamu zobrazí se po stisknutí klávesy Ins dotaz, zda chcete číslo přidat do seznamu.
  • Esc - Text ve vyhledávací řádce se smaže.

Skupiny

Kliknutím na rozbalovací nabídku skupin vyberete požadovanou skupinu. V adresáři se pak zobrazí pouze jména, která přísluší vybrané skupině. Speciální význam má skupina Všichni. Je to skupina, která obsahuje všechna jména ze všech skupin. Je zobrazena tučně a není možné ji odstranit.

Ukazatele počtu zbývajících znaků

Slouží k rychlé orientaci, kolik znaků ještě zbývá do vyčerpání limitu. Levý ukazatel zobrazuje kolik znaků zbývá do rozdělení zprávy, pravý kolik znaků zbývá celkem.

Editor textu

Slouží k vlastnímu psaní zpráv. Text je také možné vkládat se schránky (Ctrl+V). Informace o zbývajících znacích se zobrazují ve stavovém panelu. Přímo do textu můžete vkládat přednastavené zprávy z tlačítkové lišty nebo pomocí klávesové zkratky.

Stisknutím pravého tlačítka myši v okně editoru vyvoláte kontextovou nabídku. Vybráním položky Nová zpráva (Ctrl+N) připravíte DreamCom na psaní další zprávy (zruší se zaškrtnutí v adresáři a vymaže se editor textu).

Skripty

Každému operátorovi je implicitně přiřazen určitý skript. Pokud chcete změnit toto výchozí nastavení, můžete tak učinit v okně Přiřazení SMS bran operátorům (Alt+A). Jestliže chcete jednorázově (pro jedno odeslání) změnit skript, zvolte funkci Nastavit skript pro jedno odeslání (Ctrl+G). Trvalé nastavení skriptu (pro všechna následující odesílání) provedete funkcí Nastavit skript trvale (Ctrl+Alt+G). V obou případech indikuje vybraný skript ikonka svorky vedle názvu skriptu ve stavém panelu.

Okno událostí

Okno, v kterém se zobrazují aktuální události, např. hlášení o odesílaných zprávách, stahovaných aktualizacích, chybách ve skriptu atd.

Kliknutím pravým tlačítkem myši na okno událostí se zobrazí kontextová nabídka.

Stavový panel

Ve stavovém panelu se průběžně zobrazují některé důležité informace:

  1. sekce - jméno a číslo (email) vybrané osoby
  2. sekce - skript, který přísluší vybranému kontaktu
  3. sekce - celkový počet napsaných znaků
  4. sekce - počet znaků, který zbývá do rozdělení zprávy
  5. sekce - počet zpráv, na které bude text rozdělen

Tlačítka na poslání zprávy

Tlačítkem Poslat (Ctrl+Enter) pošlete zprávu ihned (zpráva je zařazena do fronty a čas odeslání nastaven na aktuální). Stisknutím tlačítka [image] (Poslat jindy) (Ctrl+J) otevřete okno Nastavení času odeslání:

Zde máte možnost nastavit, datum a čas odeslání zprávy, zda se má odeslání opakovat a jakým způsobem. Můžete určit v jakých časových intervalech se má odeslání opakovat.

Zprávu můžete také poslat z příkazové řádky.


Adresář

Okno Adresář slouží k úpravě informací o osobě v seznamu adresátů, příp. při přidávání nové osoby do seznamu.

ZÁKLADNÍ

Zde vyplňte potřebné informace o kontaktu: jméno, příjmení (pořp. přezdívku), tel. číslo a email. V políčku Zobrazovat jméno vyplňte označení kontaktu tak, jak chcete, aby se zobrazovalo v programu. Číslo mobilního telefonu uvádějte v mezinárodním formátu.

ROZŠÍŘENÉ

Oslovení

Text, který se bude přidávat na začátek každé zprávy (pokud je v nastavení zaškrtnuta volba přidávat oslovení). Vyplněním oslovení ušetříte čas při psaní jednotlivých zpráv. Tato funkce je také užitečná při hromadné korespondenci - i když píšete skupině osob, každá je oslovena svým jménem.

Podpis

Text, který se bude přidávat na konec každé zprávy (pokud je v nastavení zaškrtnuta volba přidávat podpisy). Pro každou osobu v adresáři si můžete nastavit jiný podpis či pozdrav.

Místo implicitní SMS brány používat tuto:

Určuje skript (SMS bránu), který bude automaticky použit při odesílání zprávy.

Aktivovat funkce

Určuje, jakým způsobem bude zpráva odeslána. Pokud zvolený operátor (jeho SMS brána) příslušnou funkci nepodporuje, je zatržítko zakázáno.

  • Flash SMS - zpráva se zobrazí přímo na displeji mob. telefonu (neuloží se do seznamu přijatých zpráv).
  • Potvrzení o doručení - z SMS centra operátora přijde potvrzení o přijetí SMS zprávy.
  • Identifikace - k SMS zprávě jsou přidány informace o odesílateli.

Skupiny

U každé osoby v adresáři můžete zvolit, do které skupiny bude zařazena.

TEL. ČÍSLA

U každého kontaktu můžete evidovat více tel. čísel. Aktivní však může být v daný okamžik jen jedno. Tel. číslo se stane aktivním kliknutím na tlačítko Výchozí.

EMAILY

U každého kontaktu můžete evidovat více emailů. Aktivní však může být v daný okamžik jen jeden. Email se stane aktivním kliknutím na tlačítko Výchozí.


Nastavení

V okně Nastavení se upravují parametry, které zásadním způsobem ovlivňují chování programu.

ZÁKLADNÍ

Uživatel

Email je email na který máte program zaregistrován. Používá se např. při identifikaci nebo při přihlašování k některým SMS branám. Jméno a číslo mobilního telefonu se používá rovněž k identifikaci.

Typ připojení: Pokud jste k internetu připojeni přes modem (analogový nebo ISDN), vyberte "Vytáčené". Jestliže jste připojeni pevnou linkou, přes kabelový modem nebo ADSL, vyberte "Trvalé".

ROZŠÍŘENÉ

Pokud vyberete Při ukončení upozornit na neodeslané zprávy, budete při ukončení programu upozorněni na případné zprávy ve frontě.

Pokud zvolíte Upozorňovat na aktualizace, budete při startu programu automaticky upozorněni na případné nové verze DreamComu a skriptů (viz aktualizace).

Pokud je zatrženo Upozornit na použití placené sms brány, zobrazí se při odesílání placené zprávy celková cena za odeslání.

Pokud je zatrženo Upozornit při posílání zprávy skupině, zobrazí se při odesílání zprávy více než jednomu adresátovi varovná hláška.

Po odeslání odpojit aktivujte, jestliže chcete, aby se po odeslání všech zpráv z fronty DreamCom odpojil od internetu (funguje jen pro připojení modemem).

Minimalizace do traye aktivujte, jestliže chcete, aby se program minimalizoval pouze do systémové části hlavního panelu (traye).

Ikona do traye zajistí, aby se v systémové části hlavního panelu (tzv. tray) zobrazovala ikona DreamComu. Zaškrtnutím Minimalizace do traye bude program minimalizován pouze do traye (neobjeví se mezi ostatními aplikacemi v hlavním panelu).

Máte také možnost chránit historii heslem proti neoprávněným přístupům. Heslo zadejte po stisknutí tlačítka Změnit. Jestliže chcete tuto ochranu zrušit, stiskněte opět Změnit, zadejte staré heslo, a když budete požádáni o nové heslo, nechte obě políčka prázdná.

ZPRÁVY

Pokud zaškrtnete Automaticky odstraňovat diakritiku, budou ze zprávy před odesláním odstraněny háčky a čárky.

Volba Zachovat celá slova zajišťuje, aby při posílání dlouhé zprávy nebylo poslední slovo rozděleno, ale přesunuto do další zprávy.

Pokud chcete automaticky přidávat Oslovení (na začátek zprávy) a Podpis (na konec) do zprávy, zaškrtněte tato políčka (jejich hodnoty se načítají z Adresáře). Nastavte si zde také váš implicitní Podpis a Oslovení. Kliknutím na tlačítko Natavit se ke všem položkám v adresáři přiřadí zadaný podpis, resp. oslovení.

Vlastnosti textu

Tlačítka Liché zprávy Sudé zprávy nastavují typ, velikost a barvu fontu. Tyto vlastnosti se použijí při psaní zprávy, a zajistí vizuální odlišení lichých a sudých zpráv, tak jak budou rozděleny při odeslání.

GSM

Pokud používáte mobilní telefon připojený k počítači, nastavte komunikační port a rychlost, na které se bude pracovat. Některé telefony při práci s SMS zprávami nepodporují tzv. PDU mód (např. Motoroly). V takovém případě nastavte textový mód. Jestliže chcete, aby nebyl telefon neustále připojený (aby ho mohly například využívat jiné aplikace), zatrhněte Po odeslání všech zpráv odpojit telefon.


Aktualizace

Pokud máte v Nastavení zatrženo Upozorňovat na aktualizace, objeví se po spuštění DreamComu okno Aktualizace (jen v případě, že se na internetu vyskytuje novější verze programu nebo skriptu). Jednorázově lze aktualizaci spustit z menu Program->Aktualizace (Alt+U). Objeví se okno podobné následujícímu:

V sekci Nová verze programu se objeví informace o poslední vydané verzi, v případě, že je novější, než ta, kterou máte nainstalovánu. Jsou zde uvedeny údaje o verzi programu, velikosti a jménu souboru a novinky oproti poslední verzi.

V sekci Nové skripty se objevují nové skripty nebo nové verze existujících skriptů. U každého skriptu je uvedena verze a stručná charakteristika. Máte možnost si zvolit skript, který chcete aktualizovat.

Kliknutím na tlačítko Blacklist zařadíte zaškrtnuté skripty na "černou listinu". Takové skripty už se nebudou při dalších aktualizacích nabízet. Pokud kliknete na tlačítko >>, zobrazí se rozšířená část aktualizace se zobrazenou černou listinou.

Odtud můžete skripty odstranit a zařadit je tak na seznam skriptů, které se mají při aktualizaci nabízet.

Aktualizace se provede stiskem tlačítka Stáhnout. Po stažení nové verze DreamComu můžete ihned spustit instalaci.


Příkazová řádka

DreamCom nyní umožňuje posílat zprávy přímo z příkazové řádky. Syntaxe je následující:

dreamcom.exe /num<jméno nebo číslo adresáta> TEXT TYP_ZPRAVY SKRIPT PREPINACE

TEXT je text zprávy, může být zadán:

  • přímo: /text<text zpávy>
  • ze souboru: /file<úplná cesta k souboru>

TYP_ZPRAVY může nabývat následujících hodnot:

  • /email ... odešle zprávu jako email (můžete použít parametr /subj<předmět zprávy>)
  • /picture .. odešle obrázkovou zprávu
  • /melody ... odešle melodii

Pokud neuvedete žádný typ, zpráva se odešle jako standardní textová sms zpráva.

SKRIPT určuje skript, přes který bude zpráva odeslána

PREPINACE určují tyto vlastnosti odeslání (platí jen pro odeslání přes Web):

  • doručenka: /aod
  • přímo na displej: /flash
  • identifikace: /ident
  • minimalizace při startu: /minimize

Za parametr /num se zadává číslo nebo jméno adresáta.

Na pořadí parametrů nezáleží.

Pro odesílání zpráv se používá vždy jedna instance programu. Pokud zadáte zprávu z příkazové řádky, a program již je spuštěn, DreamCom se pouze přesune do popředí a zprávy se uloží do fronty.

Příklady

dreamcom.exe /num 605123456 /text Zprava z DreamComu. /web

Pošle zpávu přes Web a vhodný skript se pokusí najít sám.

dreamcom.exe /num 605123456 /text Zprava z DreamComu. /script t-zones /aod

Pošle zpávu přes skript T-Zones se zapnutou doručenkou.

dreamcom.exe /num Milan /text Zprava z DreamComu. /email /subject Pozdrav

Pošle Milanovi (musí být v adresáři) email z předmětem Pozdrav.

dreamcom.exe /num Milan /file d:\texty\pozdrav.txt /ident

Pošle zpávu, kterou načte ze souboru, a zapne identifikaci.

Dávkové zpracování

Pokud chcete z příkazové řádky odeslat více zpráv, je výhodnější použít dávkové zpracování. Nejdříve si připravíte dávkový soubor (syntaxe je stejná jako u příkazové řádky, jen "dreamcom.exe" je možné vynechat. Pak stačí spustit DreamCom s parametrem /batch a názvem souboru s dávkou.

Příklad příkazové řádky

dreamcom.exe /batch d:\data\davka.txt

Příklad dávkového souboru

/num 605123456 /text Zprava z DreamComu.
/num 605123456 /text Zprava z DreamComu. /script t-zones /aod
/num Milan /text Zprava z DreamComu. /email /subject Pozdrav
/num Milan /file d:\texty\pozdrav.txt /ident


Export a import

Je možné provést import a export tabulek adresáře, skupin, fronty, historie, přijatých zpráv, odkazů a šablon. Pro import resp. export se používají soubory ve formátu CSV (text oddělený středníky).

První řádek v importovaném CSV souboru musí obsahovat názvy polí. Kompletní seznam názvů polí získáte kliknutím na tlačítko Názvy polí v okně Importu tabulky.

Import tabulky adresáře je možné ještě provést z programu Microsoft Outlook, Gatekeeper nebo přímo z mobilního telefonu:

Před provedením importu můžete vybrat skupinu, do které se import provede. Pokud zatrhnete volbu Synchronizovat, přepíší se kontakty se stejným jménem, příjmením a přezdívkou. V opačném případě se tyto záznamy přidají, jména budou duplicitní.


Popis skriptu

1. Struktura skriptu

2. Proměnné určené pro zápis

2.1. Povinné proměnné používané v proceduře StatInit

Version, MsgSizes, Countries

2.2. Nepovinné proměnné používané v proceduře StatInit

Author, CountryCode, Prefixes, MsgTime, QueueTime, AoDAvail, IdentAvail, FlashAvail, AoDOn, AoDOff, IdentOn, IdentOff, FlashOn, FlashOff, Official, PasswordLabel, UserPar1Label, UserPar2Label, UserPar3Label, UserPar4Label, Info, PrefSubst

2.3. Nepovinné proměnné používané v proceduře DynInit nebo Send

IdentActive, AodActive, FlashActive

3. Proměnné určené pouze pro čtení (funkce) používané v proceduře DynInit nebo Send

IPhone, ICode, Prefix, PhoneNP, Message, Email, Subject Phase, MyEmail, MyName, MyICode, MyPrefix, MyPhoneNP, Password, UserPar1, UserPar2, UserPar3, UserPar4

4. Procedury a funkce používané v kdekoliv ve skriptu

function Translate(Key);

5. Procedury a funkce používané v proceduře DynInit nebo Send

procedure GetPage(URL, Message);
procedure PostPage(URL, Fields, Message);
procedure GetPageEx(Frame: integer; URL, Message; Delay: integer);
procedure PostPageEx(Frame: integer; URL, Fields, Message; Delay: integer);
procedure AddResult(Search, Print; Action: integer);
procedure AddLog(Message, Recipient; Error: Boolean; Info);
function GetAoD;
function GetFlash;
function GetIdent;
function MD5(Source);
function FindTextBetween(StartStr, EndStr);
function GetHTMLSource;
function GetPictureInput(URL: String): String;

5.1. Konstanty používané v AddResult

Success, Retry, Queue, QueueWhen, Cancel, Resume, Exceeded, SuccessContinue

6. Příklady skriptů

1. Struktura skriptu

Syntaxe skriptu je založena na Object Pascalu, ve většině je shodná. Odlišnosti a další informace naleznete na http://www.dwscript.com.

Skript musí obsahovat dvě povinné procedury StatInit a Send, dále může obsahovat procedury DynInit a AfterKeyPress a libovolný počet uživatelem definovaných procedur a funkcí. Skript má následující strukturu:

procedure StatInit;
begin
...
end;

...
volitelné procedury a funkce
...

procedure Send(Index: integer);
begin
...
end;

case ParamStr(0) of
'STATINIT' : StatInit;
'SEND' : Send(Phase);
'DYNINIT' : DynInit; // jen pokud jsou funkce definované (volitelné)
'KEYPRESS': AfterKeyPress; // jen pokud jsou funkce definované (volitelné)
end;

StatInit - statická inicializace proměnných, smí se přiřazovat pouze konstanty, povolená je pouze funkce Translate. Provádí se při startu aplikace (načítání skriptu).
DynInit - dynamická inicializace proměnných, smí se použít libovolná proměnná či funkce. Provádí se před odesláním zprávy.
KeyPress - dynamická inicializace proměnných, smí se použít libovolná proměnná či funkce. Provádí se při stisku klávesy v editoru.
Send(Index: integer) - vlastní odesílání zpráv, v parametru Index je fáze odesílání (číslováno od nuly).

2. Proměnné určené pro zápis

2.1. Povinné proměnné používané v proceduře StatInit

Version: Float;
Verze skriptu ve formátu major.minor, např. 1.2.

MsgSizes: String;
Středníkem oddělený seznam veliskostí zpráv, např. '153;156;156;156;156'.

Countries: String;
Středníkem oddělený seznam zkratek zemí do kterých skript odesílá, např. 'CH;DE;AU'. Pro mezinárodní skripty se používá 'INT', pro ostatní viz tabulka kódů států.

2.2. Nepovinné proměnné používané v proceduře StatInit

CountryCode: integer;
Kód státu, do kterého skript odesílá. Používá se jen k automatickému přiřazování skriptu u adresáta.

Author: String;
Jméno autora skiptu a za středníkem kontaktní URL např. 'DreamTeam;mailto:kubiksms@dreamcom.cz'

Prefixes: String;
Středníkem oddělený seznam předčíslí, na které daný skript odesílá, např. '603;604;605;73'

MsgTime: integer;
Čas v sekundách, který vymezuje interval mezi odesláním 2 po sobě jdoucích zpráv.

QueueTime: String;
Řetězec na rozpoznání doby, za kterou bude možno odesílat další zprávu, např. 'NAME="smstime" VALUE="'.

AoDAvail: Boolean;
SMS brána podporuje oznámení o doručení zprávy (doručenka).

IdentAvail: Boolean;
SMS brána podporuje identifikaci.

FlashAvail: Boolean;
SMS brána podporuje odeslání zprávy pouze na displej mobilu (flash).

AoDOn: String;
Řetězec, který definuje zapnutou doručenku (řetězec vrátí fce GetAoD při zapnuté doručence).

AoDOff: String;
Řetězec, který definuje vypnutou doručenku (řetězec vrátí fce GetAoD při vypnuté doručence).

IdentOn: String;
Řetězec, který definuje zapnutou identifikaci (řetězec vrátí fce GetIdent při zapnuté identifikaci).

IdentOff: String;
Řetězec, který definuje vypnutou identifikaci (řetězec vrátí fce GetIdent při vypnuté identifikaci).

FlashOn: String;
Řetězec, který definuje zapnutou funkci flash (řetězec vrátí fce GetFlash při zapnuté flash sms).

FlashOff: String;
Řetězec, který definuje vypnutou funkci flash (řetězec vrátí fce GetFlash při vypnuté flash sms).

Official: Boolean;
Pokud nastaveno na True, je skript neoficiální a nebude automaticky doplňován u adresátů.

PasswordLabel: String;
Skript vyžaduje přihlášení heslem, hodnota je text, který se zobrazuje na kartě skriptů.

UserPar1Label: String;
Uživatelská proměnná používaná při odesílání zprávy, hodnota je text, který se zobrazuje na kartě skriptů. Obvykle se jedná o uživatelské jméno (při přihlašování).

UserPar2Label: String;
Popis další uživatelské proměnné.

UserPar3Label: String;
Popis další uživatelské proměnné.

UserPar4Label: String;
Popis další uživatelské proměnné.

Info: String;
Doplňující informace o skriptu, které se zobrazují při kliknutí na i v hlavním okně a na kartě skriptů.

PrefSubst: String;
Středníkem oddělený seznam substitucí předčíslí, např. '601=1;602=2;606=3' znamená, že předčíslí 601 bude nahrazeno hodnotou 1 atd.

2.3. Nepovinné proměnné používané v proceduře DynInit nebo Send

IdentActive: Boolean;
Vrací True, pokud je u odesílané zprávy aktivována identifikace.

AodActive: Boolean;
Vrací True, pokud je u odesílané zprávy aktivována doručenka.

FlashActive: Boolean;
Vrací True, pokud je u odesílané zprávy aktivována flash sms.

3. Proměnné určené pouze pro čtení (funkce) používané v proceduře DynInit nebo Send

IPhone: String;
Tel. číslo adresáta v mezinárodním formátu.

ICode: String;
Kód státu z čísla adresáta (bez plusu a úvodních nul).

Prefix: String;
Předčíslí z čísla adresáta.

PhoneNP: String;
Číslo adresáta bez předčíslí a kódu země.

Message: String;
Text odesílané zprávy.

Email: String;
Emailová adresa příjemce zprávy.

Subject: String;
Předmět emailu.

Phase: integer;
Fáze odesílání, číslováno od nuly, tzn. že Phase=0 je první fáze.

MyEmail: String;
Email uživatele.

MyName: String;
Jméno uživatele.

MyICode: String;
Kód státu z tel. čísla uživatele.

MyPrefix: String;
Předčíslí z tel. čísla uživatele.

MyPhoneNP: String;
Tel. číslo uživatele (bez plusu a úvodních nul)

Password: String;
Heslo pro přihlášení k sms bráně.

UserPar1: String;
Hodnota uživatelské proměnné.

UserPar2: String;
Hodnota uživatelské proměnné.

UserPar3: String;
Hodnota uživatelské proměnné.

UserPar4: String;
Hodnota uživatelské proměnné.

4. Procedury a funkce používané v kdekoliv ve skriptu

function Translate(Key: String): String;
Podle klíče Key vyhledá v příslušném .lng souboru odpovídající překlad v závislosti na nastaveném jazyce.

5. Procedury a funkce používané v proceduře DynInit nebo Send

procedure GetPage(URL, Message: String);
Načte stránku URL a v okně událostí zobrazí hlášku Message.

procedure PostPage(URL, Fields, Message: String);
Provede post stránky URL. V parametru Fields jsou názvy prvků formuláře - ve formátu 'nazev1=hodnota1&nazev2=hodnota2' atd. Následně se zobrazí hláška Message v okně událostí.

procedure GetPageEx(Frame: integer; URL, Message: String; Delay: integer);
Rozšířená verze procedury GetPage:
Frame - pořadové číslo framu, číslováno od 1. Pokud je Frame=0, framy se ignorují.
URL - adresa stránky.
Message - hláška, která se zobrazí v okně událostí.
Delay - pauza před započetím další fáze odesílání(v milisekundách).

procedure PostPageEx(Frame: integer; URL, Fields, Message: String; Delay: integer);
Rozšířená verze procedury PostPage:
Frame - pořadové číslo framu, číslováno od 1. Pokud je Frame=0, framy se ignorují.
URL - adresa stránky.
Fields - názvy prvků formuláře, jsou ve formátu 'nazev1=hodnota1&nazev2=hodnota2' atd.
Message - hláška, která se zobrazí v okně událostí.
Delay - pauza před započetím další fáze odesílání(v milisekundách).

procedure AddResult(Search, Print: String; Action: integer);
Pokud je v právě načtené stránce nalezen řetězec Search, zobrazí se v okně událostí řetězec Print a provede se akce Action (viz Konstanty používané v AddResult).

procedure AddLog(Message, Recipient: String; Error: Boolean; Info: String);
Zobrazí hlášku Message v okně událostí. Recipient je jméno adresáta, Info jsou doplňující informace. Pokud je Error=True, zobrazí se vykřičník.

function GetAoD: String;
Vrátí řetězec, který představuje zapnutou či vypnutou doručenku.

function GetFlash: String;
Vrátí řetězec, který představuje zapnutou či vypnutou flash sms.

function GetIdent: String;
Vrátí řetězec, který představuje zapnutou či vypnutou identifikaci.

function MD5(Source: String): String;
Vrátí hash řetězce Source.

function FindTextBetween(StartStr, EndStr: String): String;
Vrátí řetězec ze zdrojového kódu právě načtené stránky, který se nachází mezi řetězci StartStr a EndStr.

function GetHTMLSource: String;
Vrátí zdrojový kód právě načtené stránky (framu).

function GetPictureInput(URL: String): String;
Po zavolání této funkce se otevře dialogové okno se zobrazenou HTML stránkou (adresa je v parametru URL). Uživatel má pak možnost zadat text, který funkce vrátí jako výstup. Obvykle se používá, pokud sms brána po uživateli vyžaduje opsání kontrolního řetězce.

V procedurách GetPage, PostPage, GetPageEx a PostPageEx je možné jako hodnotu parametru Message zadat jeden z řetězců: "Msg_Sent, Msg_Loading, Msg_Sending, Msg_Expired, Msg_Later, Msg_WrongNum, Msg_Logging, Msg_Limit, Msg_Accepted, Msg_WrongPass, Msg_Reg". Ten pak bude nahrazen příslušným překladem z .lng souboru. Stejně tak funguje u procedury AddResult parametr Print.

5.1. Konstanty používané v AddResult

Success: integer = 1;
Zpráva byla úspěšně odeslána, bude vyřazena z fronty a přidána do historie.

Retry: integer = 2;
Bude ihned proveden nový pokus o odeslání.

Queue: integer = 3;
Zpráva zůstane zůstane zařazena ve frontě a její odesílání se ukončí.

QueueWhen: integer = 4;
Ukončí se odesílání zprávy, odesílat se začne znovu v čas, který se získá z sms brány.

Cancel: integer = 5;
Odesílání zprávy bude ukončeno.

Resume: integer = 6;
Bude se pokračovat ve vykonávaní skriptu.

Exceeded: integer = 7;
Byl vyčerpán limit odeslaných práv pro danou sms bránu. SuccessContinue: integer = 8;
Zpráva byla úspěšně odeslána, bude vyřazena z fronty a přidána do historie a poté ještě bude zavolána další fáze. V této fázi již nesmíte odesílat! Použijte ji jen na zobrazení nějakých užitečných informací z odpovědi brány.

6. Příklady skriptů

Jednoduchý skript
Složitější skript


Registrace programu

Registrace programu DreamCom

Registrace programu stojí 300 Kč, tato částka zahrnuje upgrade zdarma po dobu jednoho roku od zakoupení registrace. Po uplynutí jednoho roku je program stále registrovaný, ale není již možné provést bezplatný upgrade na novou verzi.

Registrací získáte:

  • Zmizí reklamní pruh a nutnost na něj klikat.
  • Možnost vytvářet vlastní skripty.
  • Možnost odesílat opakované zprávy.
  • Možnost odesílat přes skripty, které jsou určeny jen pro registrované uživatele, podrobnosti zde.
  • Při odesílání přes mobilní telefon se nepřidává reklamní text.
  • Neomezený import kontaktů z mobilního telefonu (neregistrovaná verze načte jen 10 kontaktů).

Registrace je prováděna převodem na účet, je vázána k emailu, který máte vyplněn v nastavení.

Licencování:
Program můžete používat na libovolném počtu počítačů (doma, v práci, atd..) ale vždy ho může používat pouze ta osoba, na kterou byl program registrován. Na každých 5 licencí je poskytována 300 Kč sleva. Tedy za 5 licencí zaplatíte 1200 Kč, za 10 licencí 2400Kč atd.

Dále je možné zakoupit multilicenci pro firmu - neomezený počet licencí pro všechny firemní zaměstnance (kontrolována je jen doména u emailu např. asus.cz, microsoft.cz). Cena multilicence je 990 Kč.

Pokud se tedy chcete zaregistrovat pošlete email na objednavka@dreamcom.cz , zde uveďte:

  • Váš email, na který chcete program zaregistrovat
  • V případě, že potřebujete daňový doklad, uveďte tuto skutečnost a pošlete veškeré fakturační údaje, včetně IČO a DIČ

Druhou (a jednodušší) možností je vyplnit formulář na webu.

Obratem dostanete informaci o úspěšné objednávce a variabilní symbol, po zaplacení dostanete registrační soubor.

Domovská stránka DreamComu: http://www.dreamcom.cz


{ Skript to branu Bramka.org }

procedure StatInit;
begin
// Povinné parametry:
  Version := 1.3; // číslo verze skriptu
  MsgSizes := '160'; //velikosti jednotivých zpráv oddělených středníkem, tedy v tomto případě jedna zpráva
  Countries := 'PL'; // onzačení do jakých zemí lze odesílat, INT je mezinárodní skript, jinak zkratky zemí ze staty.dat
// Nepovinné parametry:
  Prefixes := '501;603'; //seznam prefixů, které podporuje daná brána
end;

procedure Send(index: integer);
begin
  case index of
    0: begin // první fáze odesílání
      GetPage(
        'http://www.bramka.org/sms/index.php', // URL sms brány
        'Msg_Loading');         // hlaska do okna událostí
    end;
    1: begin //druhá fáze odesílání
      AddResult('SMS został poprawnie wysłany.', 'Msg_Sent', Success); // pokud se na stránce nachází řetězec 'byla odesl', v okně událostí se zobrazí hláška o odeslání zprávy a odesílání je úspěšně ukončeno (Success)
      PostPage(
        'http://www.bramka.org/sms/send.php'
        'strPhoneNumber='+Prefix+PhoneNP+'&strText='+Message+'&Submit=Wysłat', //seznam názvů a hodnot polí
        'Msg_Sending'); // hláška do okna událostí
    end;
  end;
end;

case ParamStr(0) of // vlastní vykonávání skriptu
  'STATINIT' : StatInit; // povinné - volá se statická inicializace proměnných
  'SEND' : Send(Phase); // povinné - volá se procedura Send
end;


{Hlavicka skriptu, libovolne info, o autorovi atd.
Skript pro SMS branu http://web.icq.com/sms/inbox
Autor: DreamTeam}

procedure StatInit; //inicializace proměnných při prvním načtení
begin
  Version := 1.0; //číslo verze skriptu
  MsgSizes := '160;155'; //velikosti jednotivých zpráv oddělených středníkem
  Countries := 'INT'; //onzačení do jakých zemí lze odesílat, INT je mezinárodní skript, jinak zkratky zemí ze staty.dat

  //Nepovinné parametry:
  PasswordLabel := Translate('Password') + ':'; // skript vyžaduje přihlášení heslem, hodnota je text, který se zobrazuje na kartě skriptů
  UserPar1Label := Translate('UserName') + ':'; // skript vyžaduje přihlášení uživ. jménem, hodnota je text, který se zobrazuje na kartě skriptů, už. paramterů může být až 5
  Prefixes := '603;604;605'; //seznam prefixů, které podporuje daná brána
  CountryCode := 420; //Kód státu, do kterého skript odesílá. Používá se jen k automatickému přiřazování skriptu u adresáta.
  MsgTime := 120;  //za jak dlouho je možné odeslat další zprávu
  QueueTime := 'NAME="smstime" VALUE="'; //řetězec na rozpoznání doby, za kterou bude možno odesílat
  AoDAvail := True;   // brána podporuje doručenku
  FlashAvail := True; // brána podporuje flash
  IdentAvail := True; //brána podporuje Identifikaci odesílatele
  AoDOff := '';  //řetězec, který vrátí fce GetAod při vypnuté doručence
  FlashOn := 'flash=true'; //řetězec, který vrátí fce GetFlash při zapnuté doručence
  FlashOff := 'flash=false'; //řetězec, který vrátí fce GetFlash při vypnuté doručence
  IdentOff := ''; // řetězec, který vrátí fce GetIdent při vypnuté identifikaci
  Official := false; //tento skript je neoficiální a nebude automaticky doplňován u adresátů
  Info := 'Omezení 5 zpráv denně...'; //doplňující informace o skriptu, které se zobrazují při kliknutí na i v hlavním okně a na kartě skriptů
end;

procedure DynInit; //nepovinná procedura, volá se při změně adresáta v editoru, při změně doručenky či identifikace, před odesláním zprávy
begin
  IdentOn := MyEmail; //do této procedury dejte inicializaci proměnných, které nejsou naplňovány konstantou
  if Pos(Prefix,'608;776;777') > 0 then begin //Pokud je prefix 608 či 776 či 777
    Aod := false; Ident := false; MsgSizes := '152;152;152;152;152';
  end;
end;

procedure AfterKeyPress; //nepovinná procedura, volá se při stisku klávesy v editoru
begin
  if Length(Message) > 158 then MsgSizes := '156;156;154' else MsgSizes := '158;156;154';
end;

procedure Send(index: integer); //povinná procedura, v které probíhá vlastní odesílání zprávy (index označuje fázi, ve které se odesílání nachází)
begin
  case index of
    0: begin //první fáze odesílání
      GetPage('http://web.icq.com/sms/inbox', 'Msg_Loading'); //načte zadanou webovou stránku a zobrazí hlášku o načítání úvodní stránky v okně událostí
    end;
    1: begin //druhá fáze odesílání
       if Pos('Hello', GetHTMLSource) > 0 then begin Phase := 2; Send(Phase); exit; end; //pokud se na stránce vyskytuje zadaný řetězec, přejde se na 3. fázi (zbytek 2. fáze se už neprovede)
       AddResult('Hello', 'Msg_Accepted', Resume); //pokud se na stránce nachází řetězec 'Hello', v okně událostí se zobrazí hláška o přijetí hesla a pokračuje se další fází odesílání (Resume)
       AddResult('are incorrect','Msg_WrongPass', Cancel); //pokud se na stránce nachází řetězec 'are incorrect', v okně událostí se zobrazí hláška o špatném hesle a odesílání je ukončeno (Cancel)
       PostPage(
        'http://web.icq.com/sms/inbox/login.php',
        'karma_user_login=' + UserPar1 + '&karma_user_passwd=' + Password + '&Submit=Login'', //názvy prvků formuláře jsou ve formátu 'nazev1=hodnota1&nazev2=hodnota2' atd.
        'Msg_Logging', //v okně událostí zobrazí hlášku o ověřování jména a hesla
        0); //pauza před započetím další fáze (v milisekundách)
     end;
    2: begin //třetí fáze odesílání
      AddResult('has been successfully sent.','Msg_Sent', Success); //pokud se na stránce nachází řetězec 'has been successfully sent.', v okně událostí se zobrazí hláška o odeslání zprávy a odesílání je úspěšně ukončeno (Success)
      AddResult('could not be sent', 'Msg_WrongNum', Cancel); //špatně zadané číslo, odesílání je ukončeno
      PostPage(
        'http://web.icq.com/sms/inbox/send.php',
        'country=' + ICode + '&carrier=' + Prefix + '&tophone=' + PhoneNP + '&msg=' + Message + '&Submit=Send', //názvy prvků formuláře
        'Msg_Sending', //zobrazí se hláška v okně událostí
        0); //žádná pauza
    end;
  end;
end;

case ParamStr(0) of //vlastní vykonávání skriptu
  'STATINIT' : StatInit; //povinné - volá se statická inicializace proměnných
  'DYNINIT' : DynInit; //nepovinné - volá se dynamická inicializace proměnných
  'SEND' : Send(Phase); //povinné - volá se procedura Send
end;


Uživatelské profily

V menu Nastavení->Správa uživatelů máte možnost vytvářet profily uživatelů. To je výhodné, pokud chcete, aby DreamCom využívalo více lidí. Každý pak bude mít vlastní Adresář (a ostatní databáze) a nastavení. Všechny uživatelské databáze jsou kódované, a tak je pro neoprávněné osoby nemožné do nich nahlížet. Pokud vytvoříte alespoň jednoho uživatele, zobrazuje se při startu programu přihlašovací obrazovka.

Zde máte možnost přihlásit se pod zvoleným profilem. Pokud je profil chráněný heslem, musíte zadat správné heslo a stisknout tlačítko OK. Stisknutím tlačítka Storno se program spustí s profilem implicitního uživatele. Databáze implicitního uživatele nejsou kódovány (kromě historie).

Stisknutím tlačítka Přidat vytvoříte nový uživatelský profil.

Musíte zadat unikátní uživatelské jméno. Dále můžete ochránit profil heslem. Pokud zatrhnete volbu zkopírovat aktuální data, budou pro nově vytvořený profil použita aktuální data. Zatrhnete-li volbu vymazat aktuální data, aktuální data se po vytvoření profilu vymažou.

Stisknutím tlačítka Odebrat odstraníte vybraný uživatelský profil. Pokud je profil chráněný heslem, musíte ho nejdříve zadat.

Stisknutím tlačítka Změnit se otevře okno na editaci vybraného profilu (obdoba okna pro vytvoření nového profilu).

Stisknutím tlačítka Výchozí bude vybraný profil označen jako výchozí. Při každém startu aplikace bude tento profil automaticky označen.